Back to overview
Resolved

Exchange maintenance

Jun 7, 2026 at 6:00pm UTC  –  Jun 7, 2026 at 6:10pm UTC
Affected services
ondoperps.xyz

Resolved
Jun 7, 2026 at 6:10pm UTC

Maintenance ended

Created
Jun 7, 2026 at 6:00pm UTC

We will have a brief period of unavailability while we perform maintenance on the exchange system. Please check here for updates.