Back to overview
Resolved

Exchange functionality is degraded

Jun 4, 2026 at 7:27am UTC
Affected services
ondoperps.xyz

Resolved
Jun 4, 2026 at 7:27am UTC

Exchange functionality is degraded, going expect disconnects. A fix is being actively worked on.