Back to overview
Resolved

Trading engine upgrade

May 28, 2026 at 8:45pm UTC  –  May 28, 2026 at 8:55pm UTC
Affected services
ondoperps.xyz

Resolved
May 28, 2026 at 8:55pm UTC

Maintenance ended

Created
May 28, 2026 at 8:45pm UTC

We are performing maintenance on the exchange system, please check here for updates.