Back to overview
Resolved

Exchange Maintenance

Sep 3, 2026 at 5:15am UTC  –  Sep 3, 2026 at 5:30am UTC
Affected services
ondoperps.xyz

Resolved
Sep 3, 2026 at 5:30am UTC

Maintenance ended

Created
Sep 3, 2026 at 5:15am UTC

We are performing maintenance on the exchange system. Please check back here for updates.