Back to overview
Resolved

Exchange temporarily unavailable

Aug 7, 2026 at 3:59pm UTC
Affected services
ondoperps.xyz

Resolved
Aug 7, 2026 at 6:55pm UTC

The issue has been resolved.

Updated
Aug 7, 2026 at 5:07pm UTC

We’re currently experiencing performance degradation, which may result in slower response times or intermittent errors. We’re investigating the issue and will provide an update as more information becomes available.

Created
Aug 7, 2026 at 3:59pm UTC

We are aware of an incident impacting exchange availability and are investigating. Please check back here for updates.